import re
regex = re.compile(r"(?<pnum>[\dA-Z]{9}).(?<nat>\w{3})(?<yob>\d{2})(?<mob>\d{2})(?<dob>\d{2}).(?<sex>M|F|<{1})(?<yoe>\d{2})(?<moe>\d{2})(?<doe>\d{2}).(?<prnum>[]\d|<A-Z]{16})")
test_str = "XDB0602173ESP9009224M1808052RE20040086234046"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")