// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<pnum>[\dA-Z]{9}).(?<nat>\w{3})(?<yob>\d{2})(?<mob>\d{2})(?<dob>\d{2}).(?<sex>M|F|<{1})(?<yoe>\d{2})(?<moe>\d{2})(?<doe>\d{2}).(?<prnum>[]\d|<A-Z]{16})").unwrap();
let string = "XDB0602173ESP9009224M1808052RE20040086234046";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}