const regex = /(?<pnum>[\dA-Z]{9}).(?<nat>\w{3})(?<yob>\d{2})(?<mob>\d{2})(?<dob>\d{2}).(?<sex>M|F|<{1})(?<yoe>\d{2})(?<moe>\d{2})(?<doe>\d{2}).(?<prnum>[]\d|<A-Z]{16})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<pnum>[\\dA-Z]{9}).(?<nat>\\w{3})(?<yob>\\d{2})(?<mob>\\d{2})(?<dob>\\d{2}).(?<sex>M|F|<{1})(?<yoe>\\d{2})(?<moe>\\d{2})(?<doe>\\d{2}).(?<prnum>[]\\d|<A-Z]{16})', '')
const str = `XDB0602173ESP9009224M1808052RE20040086234046`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}