use strict;
my $str = 'XDB0602173ESP9009224M1808052RE20040086234046';
my $regex = qr/(?<pnum>[\dA-Z]{9}).(?<nat>\w{3})(?<yob>\d{2})(?<mob>\d{2})(?<dob>\d{2}).(?<sex>M|F|<{1})(?<yoe>\d{2})(?<moe>\d{2})(?<doe>\d{2}).(?<prnum>[]\d|<A-Z]{16})/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}