#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ":\s*([^,]+)"
Local $sString = "It sent a notice of delivery of goods: UserName1 (00215478),UserName2 (00258747)" & @CRLF & _
"Sent a notice of delivery of the goods: User is not found, UserName2 (00258747)" & @CRLF & _
"It sent a notice of receipt of the goods: UserName1 (00215478),UserName2 (00258747)" & @CRLF & _
"It sent a notice of receipt of the goods: User is not found, UserName2 (00258747)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")