import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":\\s*([^,]+)";
final String string = "It sent a notice of delivery of goods: UserName1 (00215478),UserName2 (00258747)\n"
+ "Sent a notice of delivery of the goods: User is not found, UserName2 (00258747)\n"
+ "It sent a notice of receipt of the goods: UserName1 (00215478),UserName2 (00258747)\n"
+ "It sent a notice of receipt of the goods: User is not found, UserName2 (00258747)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}