use strict;
my $str = 'It sent a notice of delivery of goods: UserName1 (00215478),UserName2 (00258747)
Sent a notice of delivery of the goods: User is not found, UserName2 (00258747)
It sent a notice of receipt of the goods: UserName1 (00215478),UserName2 (00258747)
It sent a notice of receipt of the goods: User is not found, UserName2 (00258747)';
my $regex = qr/:\s*([^,]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}