using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":\s*([^,]+)";
string input = @"It sent a notice of delivery of goods: UserName1 (00215478),UserName2 (00258747)
Sent a notice of delivery of the goods: User is not found, UserName2 (00258747)
It sent a notice of receipt of the goods: UserName1 (00215478),UserName2 (00258747)
It sent a notice of receipt of the goods: User is not found, UserName2 (00258747)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}