re = /:\s*([^,]+)/
str = 'It sent a notice of delivery of goods: UserName1 (00215478),UserName2 (00258747)
Sent a notice of delivery of the goods: User is not found, UserName2 (00258747)
It sent a notice of receipt of the goods: UserName1 (00215478),UserName2 (00258747)
It sent a notice of receipt of the goods: User is not found, UserName2 (00258747)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end