import Foundation
let pattern = #":\s*([^,]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
It sent a notice of delivery of goods: UserName1 (00215478),UserName2 (00258747)
Sent a notice of delivery of the goods: User is not found, UserName2 (00258747)
It sent a notice of receipt of the goods: UserName1 (00215478),UserName2 (00258747)
It sent a notice of receipt of the goods: User is not found, UserName2 (00258747)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)