package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`:\s*([^,]+)`)
var str = `It sent a notice of delivery of goods: UserName1 (00215478),UserName2 (00258747)
Sent a notice of delivery of the goods: User is not found, UserName2 (00258747)
It sent a notice of receipt of the goods: UserName1 (00215478),UserName2 (00258747)
It sent a notice of receipt of the goods: User is not found, UserName2 (00258747)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}