using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<ul.*?class=([\'\""])(?:s|bbc)\1[^>]*>(.*?)(?=\<\/ul\>)<\/ul>";
string substitution = @"[list]$2[/list]";
string input = @"<ul class=""bbc""><li>mierda</li></ul>
<ul class=""bbc bbcol decimal"">
<li>mierda</li>
<li>mierda</li>
</ul>
<ul class=""bbc""><li>mierda</li></ul>";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}