use strict;
my $str = '<ul class="bbc"><li>mierda</li></ul>
<ul class="bbc bbcol decimal">
<li>mierda</li>
<li>mierda</li>
</ul>
<ul class="bbc"><li>mierda</li></ul>';
my $regex = qr/<ul.*?class=([\'\"])(?:s|bbc)\1[^>]*>(.*?)(?=\<\/ul\>)<\/ul>/ip;
my $subst = '[list]$2[/list]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";