re = /<ul.*?class=([\'\"])(?:s|bbc)\1[^>]*>(.*?)(?=\<\/ul\>)<\/ul>/i
str = '<ul class="bbc"><li>mierda</li></ul>
<ul class="bbc bbcol decimal">
<li>mierda</li>
<li>mierda</li>
</ul>
<ul class="bbc"><li>mierda</li></ul>'
subst = '[list]$2[/list]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result