$re = '/<ul.*?class=([\'\"])(?:s|bbc)\1[^>]*>(.*?)(?=\<\/ul\>)<\/ul>/i';
$str = '<ul class="bbc"><li>mierda</li></ul>
<ul class="bbc bbcol decimal">
<li>mierda</li>
<li>mierda</li>
</ul>
<ul class="bbc"><li>mierda</li></ul>';
$subst = "[list]$2[/list]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;