import Foundation
let pattern = #"<ul.*?class=([\'\"])(?:s|bbc)\1[^>]*>(.*?)(?=\<\/ul\>)<\/ul>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<ul class="bbc"><li>mierda</li></ul>
<ul class="bbc bbcol decimal">
<li>mierda</li>
<li>mierda</li>
</ul>
<ul class="bbc"><li>mierda</li></ul>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[list]$2[/list]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)