#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\d{1,2})([^\d]{1,2}(\d{1,2}))+.*"
Local $sString = "S01E01.HDTV.x264-LOL.mp4" & @CRLF & _
"S01E01E02.HDTV.x264-LOL.mp4" & @CRLF & _
"S01E01-02.HDTV.x264-LOL.mp4" & @CRLF & _
"S01E01-E02.HDTV.x264-LOL.mp4" & @CRLF & _
"" & @CRLF & _
"01x01 Lorem ipsum.avi" & @CRLF & _
"01x01-02 Lorem ipsum.avi" & @CRLF & _
"" & @CRLF & _
"1x1 Lorem ipsum.avi" & @CRLF & _
"1x1-2 Lorem ipsum.avi"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")