use strict;
my $str = 'S01E01.HDTV.x264-LOL.mp4
S01E01E02.HDTV.x264-LOL.mp4
S01E01-02.HDTV.x264-LOL.mp4
S01E01-E02.HDTV.x264-LOL.mp4
01x01 Lorem ipsum.avi
01x01-02 Lorem ipsum.avi
1x1 Lorem ipsum.avi
1x1-2 Lorem ipsum.avi';
my $regex = qr/(\d{1,2})([^\d]{1,2}(\d{1,2}))+.*/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}