const regex = /(\d{1,2})([^\d]{1,2}(\d{1,2}))+.*/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,2})([^\\d]{1,2}(\\d{1,2}))+.*', 'ig')
const str = `S01E01.HDTV.x264-LOL.mp4
S01E01E02.HDTV.x264-LOL.mp4
S01E01-02.HDTV.x264-LOL.mp4
S01E01-E02.HDTV.x264-LOL.mp4
01x01 Lorem ipsum.avi
01x01-02 Lorem ipsum.avi
1x1 Lorem ipsum.avi
1x1-2 Lorem ipsum.avi`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}