using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{1,2})([^\d]{1,2}(\d{1,2}))+.*";
string input = @"S01E01.HDTV.x264-LOL.mp4
S01E01E02.HDTV.x264-LOL.mp4
S01E01-02.HDTV.x264-LOL.mp4
S01E01-E02.HDTV.x264-LOL.mp4
01x01 Lorem ipsum.avi
01x01-02 Lorem ipsum.avi
1x1 Lorem ipsum.avi
1x1-2 Lorem ipsum.avi";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}