import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{1,2})([^\\d]{1,2}(\\d{1,2}))+.*";
final String string = "S01E01.HDTV.x264-LOL.mp4\n"
+ "S01E01E02.HDTV.x264-LOL.mp4\n"
+ "S01E01-02.HDTV.x264-LOL.mp4\n"
+ "S01E01-E02.HDTV.x264-LOL.mp4\n\n"
+ "01x01 Lorem ipsum.avi\n"
+ "01x01-02 Lorem ipsum.avi\n\n"
+ "1x1 Lorem ipsum.avi\n"
+ "1x1-2 Lorem ipsum.avi";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}