$re = '/(\d{1,2})([^\d]{1,2}(\d{1,2}))+.*/i';
$str = 'S01E01.HDTV.x264-LOL.mp4
S01E01E02.HDTV.x264-LOL.mp4
S01E01-02.HDTV.x264-LOL.mp4
S01E01-E02.HDTV.x264-LOL.mp4
01x01 Lorem ipsum.avi
01x01-02 Lorem ipsum.avi
1x1 Lorem ipsum.avi
1x1-2 Lorem ipsum.avi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);