// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\d{1,2})([^\d]{1,2}(\d{1,2}))+.*").unwrap();
let string = "S01E01.HDTV.x264-LOL.mp4
S01E01E02.HDTV.x264-LOL.mp4
S01E01-02.HDTV.x264-LOL.mp4
S01E01-E02.HDTV.x264-LOL.mp4
01x01 Lorem ipsum.avi
01x01-02 Lorem ipsum.avi
1x1 Lorem ipsum.avi
1x1-2 Lorem ipsum.avi";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}