# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:\(0[0-8]\)|0[0-8])[ ]?[0-9]{4}[ ]?[0-9]{4}$//gm;t' <<< "02 4345 2334
0243452334
(02)43452334
(02) 4345 2334"