package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\(0[0-8]\)|0[0-8])[ ]?[0-9]{4}[ ]?[0-9]{4}$`)
var str = `02 4345 2334
0243452334
(02)43452334
(02) 4345 2334`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}