use strict;
my $str = '02 4345 2334
0243452334
(02)43452334
(02) 4345 2334';
my $regex = qr/^(?:\(0[0-8]\)|0[0-8])[ ]?[0-9]{4}[ ]?[0-9]{4}$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";