import re
regex = re.compile(r"^(?:\(0[0-8]\)|0[0-8])[ ]?[0-9]{4}[ ]?[0-9]{4}$", flags=re.MULTILINE)
test_str = ("02 4345 2334\n"
"0243452334\n"
"(02)43452334\n"
"(02) 4345 2334")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)