re = /^(?:\(0[0-8]\)|0[0-8])[ ]?[0-9]{4}[ ]?[0-9]{4}$/m
str = '02 4345 2334
0243452334
(02)43452334
(02) 4345 2334'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result