import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\(0[0-8]\\)|0[0-8])[ ]?[0-9]{4}[ ]?[0-9]{4}$";
final String string = "02 4345 2334\n"
+ "0243452334\n"
+ "(02)43452334\n"
+ "(02) 4345 2334";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}