const regex = /^(?:\(0[0-8]\)|0[0-8])[ ]?[0-9]{4}[ ]?[0-9]{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\(0[0-8]\\)|0[0-8])[ ]?[0-9]{4}[ ]?[0-9]{4}$', 'gm')
const str = `02 4345 2334
0243452334
(02)43452334
(02) 4345 2334`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);