#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[2-9][0-9]{3}[^\S\r\n][0-9]{4}[^\S\r\n][0-9]{4}\b"
Local $sString = "2355 2345 7868 aaa 2355 2345 7868" & @CRLF & _
"2355" & @CRLF & _
"2345" & @CRLF & _
"7868" & @CRLF & _
"1355 2345 7868" & @CRLF & _
"235 2345 7868" & @CRLF & _
"2355 2345 786" & @CRLF & _
"2A55 2345a7868" & @CRLF & _
"235523457868"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")