package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[2-9][0-9]{3}[^\S\r\n][0-9]{4}[^\S\r\n][0-9]{4}\b`)
var str = `2355 2345 7868 aaa 2355 2345 7868
2355
2345
7868
1355 2345 7868
235 2345 7868
2355 2345 786
2A55 2345a7868
235523457868`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}