use strict;
my $str = '2355 2345 7868 aaa 2355 2345 7868
2355
2345
7868
1355 2345 7868
235 2345 7868
2355 2345 786
2A55 2345a7868
235523457868';
my $regex = qr/\b[2-9][0-9]{3}[^\S\r\n][0-9]{4}[^\S\r\n][0-9]{4}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}