import re
regex = re.compile(r"\b[2-9][0-9]{3}[^\S\r\n][0-9]{4}[^\S\r\n][0-9]{4}\b", flags=re.MULTILINE)
test_str = ("2355 2345 7868 aaa 2355 2345 7868\n"
"2355\n"
"2345\n"
"7868\n"
"1355 2345 7868\n"
"235 2345 7868\n"
"2355 2345 786\n"
"2A55 2345a7868\n"
"235523457868")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")