import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[2-9][0-9]{3}[^\\S\\r\\n][0-9]{4}[^\\S\\r\\n][0-9]{4}\\b";
final String string = "2355 2345 7868 aaa 2355 2345 7868\n"
+ "2355\n"
+ "2345\n"
+ "7868\n"
+ "1355 2345 7868\n"
+ "235 2345 7868\n"
+ "2355 2345 786\n"
+ "2A55 2345a7868\n"
+ "235523457868";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}