re = /\b[2-9][0-9]{3}[^\S\r\n][0-9]{4}[^\S\r\n][0-9]{4}\b/m
str = '2355 2345 7868 aaa 2355 2345 7868
2355
2345
7868
1355 2345 7868
235 2345 7868
2355 2345 786
2A55 2345a7868
235523457868'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end