using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[2-9][0-9]{3}[^\S\r\n][0-9]{4}[^\S\r\n][0-9]{4}\b";
string input = @"2355 2345 7868 aaa 2355 2345 7868
2355
2345
7868
1355 2345 7868
235 2345 7868
2355 2345 786
2A55 2345a7868
235523457868";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}