#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(['"])([A-Za-z]+)\1"
Local $sString = "Joe can't tell between 'large' and large."
Local $sSubst = "\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)