re = /(['"])([A-Za-z]+)\1/
str = 'Joe can\'t tell between \'large\' and large.'
subst = '\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result