const regex = /(['"])([A-Za-z]+)\1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\'"])([A-Za-z]+)\\1', 'g')
const str = `Joe can't tell between 'large' and large.`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);