using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(['""])([A-Za-z]+)\1";
string substitution = @"\2";
string input = @"Joe can't tell between 'large' and large.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}