import Foundation
let pattern = #"(['"])([A-Za-z]+)\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Joe can't tell between 'large' and large."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)