$re = '/([\'"])([A-Za-z]+)\1/';
$str = 'Joe can\'t tell between \'large\' and large.';
$subst = "\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;