use strict;
my $str = 'Joe can\'t tell between \'large\' and large.';
my $regex = qr/(['"])([A-Za-z]+)\1/p;
my $subst = '\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";