#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "alert\(.*?\);"
Local $sString = "alert(123); var hello = 0;" & @CRLF & _
"console.log(hello);"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)