import Foundation
let pattern = #"alert\(.*?\);"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
alert(123); var hello = 0;
console.log(hello);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)