use strict;
my $str = 'alert(123); var hello = 0;
console.log(hello);';
my $regex = qr/alert\(.*?\);/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";