$re = '/alert\(.*?\);/';
$str = 'alert(123); var hello = 0;
console.log(hello);';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;