const regex = /alert\(.*?\);/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('alert\\(.*?\\);', 'g')
const str = `alert(123); var hello = 0;
console.log(hello);`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);