import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/img/([0-9a-fA-F]{2})([0-9a-fA-F]+)$";
final String string = "example.com/img/fe5afe0482195afff9390692a6cc23e1";
final String subst = "/content/img/$1/$1$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}